Potential degraded internet service
Incident Report for Minnehaha Academy
Resolved
This incident has been resolved.
Posted Feb 22, 2024 - 12:19 CST
Investigating
Due to some large scale outages with different providers, we may experience partially degraded internet service if our connection temporarily needs to fall back to our backup service. We are aware of this possibility and will be monitoring and updating with any more information or status changes.
Posted Feb 22, 2024 - 08:52 CST
This incident affected: Internet (North Campus Internet Connectivity, North Campus WiFi, South Campus WiFi, South Campus Internet Connectivity).