Schoology: Some users are experiencing degraded service while using Schoology
Incident Report for Minnehaha Academy
Resolved
[Monitoring] We are actively monitoring an unprecedented, rapid increase in concurrent users on Schoology. We have taken a number of steps to improve stability and have proactively added significant additional capacity. During this time, a very small percentage of users may occasionally experience intermittent page loading errors. Refreshing the page should resolve the issue.

Our top priority is to provide site stability and availability and expect to have complete resolution as soon as possible.
Posted Apr 01, 2020 - 15:01 CDT
Update
We are continuing to monitor for any further issues.
Posted Apr 01, 2020 - 13:13 CDT
Monitoring
Some users are experiencing degraded service while using Schoology

Performance Issues
Components
Schoology Site, Support: Phone and Chat, Support: Ticket and Webform, Portfolios, Assessment Management Platform, Usage Statistics, Assessment Reports, Support: Help Center, Imports & Exports, Schoology Published Apps, API, Single Sign-On, Document Conversion, Bulk Content Transfers, Mobile Applications, Support: Developer Documentation, Student Information System Apps, Schoology Test Environment, Data Exchange

Here is Schoology's general response to the issues:
https://www.schoology.com/blog/scaling-schoology-increased-demand
Posted Apr 01, 2020 - 13:12 CDT
This incident affected: <a href="https://status.schoology.com">Schoology</a>.