Network/Phones down at South Campus
Incident Report for Minnehaha Academy
Resolved
The incident was identified and resolved. Thanks to Dan K!
Posted Jan 20, 2023 - 13:38 CST
Investigating
We are currently investigating this issue.
Posted Jan 20, 2023 - 13:20 CST
This incident affected: Telephony (South Campus Phones) and Internet (South Campus WiFi, South Campus Internet Connectivity).