Phones are down for external calls
Incident Report for Minnehaha Academy
Resolved
This incident has been resolved.
Posted May 25, 2023 - 08:53 CDT
Monitoring
Phones are up and all calling is operational. There was not a given maintenance window from Comcast, so there is a potential that they may go down again at some point today. We will be monitoring and updating with any changes.
Posted May 24, 2023 - 10:54 CDT
Identified
Inbound calling from external numbers, and dialing out to external numbers is currently down for both campuses. Comcast is working in the area and has notified us that there may be potential outages throughout the day, but they should hopefully be short and resolved quickly.
Posted May 24, 2023 - 08:40 CDT
This incident affected: Telephony (North Campus Phones, South Campus Phones).