Internet down at North Campus
Incident Report for Minnehaha Academy
Resolved
The issues was identified and resolved. Internet connectivity has been restored to North Campus.
Posted Nov 08, 2022 - 08:20 CST
Investigating
The internet at North Campus is currently down and we are investigating the issue.
Posted Nov 08, 2022 - 08:03 CST
This incident affected: Internet (North Campus Internet Connectivity, North Campus WiFi).